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PowerPad Keys

Use the following keys in PowerPad.

Moving the Insertion Point

Key(s) Function
Up Arrow Moves up one line.
Down Arrow Moves down one line.
Right Arrow Moves right one character.
Left Arrow Moves left one character.
Ctrl + Right Arrow Moves right one word.
Ctrl + Left Arrow Moves left one word.
Home Moves to the beginning of the line.
End Moves to the end of the line.
PgUp Moves up one window.
PgDn Moves down one window.
Ctrl + Home Moves to the beginning of the file.
Ctrl + End Moves to the end of the file.

Selecting Text

Key(s) Function
Shift + Left or Right Arrow Selects text one character at a time to the left or right.    Or, if 

the character is already selected, cancels the selection.
Shift + Down or Up Selects one line of text up or down.    Or, if the line is already 

selected, cancels the selection.
Shift + PgUp Selects text up on window.    Or, if the previous window is 

already selected, cancels the selection.
Shift + PgDn Selects text down one window.    Or, if the next window is 

already selected, cancels the selection.
Shift + Home Selects text to the beginning of the line.
Shift + End Selects text to the end of the line.
Ctrl + Shift + Left Arrow Selects the previous word.
Ctrl + Shift + Right Arrow Selects the next word.
Ctrl + Shift + Home Selects text to the beginning of the file.
Ctrl + Shift + End Selects text to the end of the file.



PowerPad Commands

File Menu Commands
New
Open
Merge
Save
Save As
Preferences
Print
Page Setup
Printer Setup
Exit

Edit Menu Commands
Undo
Cut
Copy
Paste
Delete
Select All

View Menu Commands
Tabs
Wordwrap

Search Menu Commands
Find
Repeat Find
Change
Goto Line

Run Menu Commands
<Command>
Options

Help Menu Commands
Index
Keyboard
Commands
Procedures
Using Help
About PowerPad



PowerPad Procedures

Editing Text
Copying Text
Cutting Text
Pasting Text
Deleting Text
Finding Text
Changing Text
Undoing Edits

Formatting Text
Setting Tab Stops
Wrapping Text

Printing
Printing Files
Changing Printers and Printer Options
Printing Headers and Footers
Setting Margins

Running Other Programs
Configuring the Run Menu
Using the Run Menu

ShareWare Registration
Registering PowerPad

Selecting Text
Using the Mouse to Select Text
Selecting All the Text in a File

Working with Files
Creating New Files
Opening Existing Files
Merging Existing files
Saving Files
Setting File Preferences
Viewing File Statistics



File Menu Commands

New
Open
Merge
Save
Save As
Preferences
Print
Page Setup
Printer Setup
Exit



Edit Menu Commands

Undo
Cut
Copy
Paste
Delete
Select All



View Menu Commands

Tabs
Wordwrap



Search Menu Commands

Find
Repeat Find
Change
Goto Line



Run Menu Commands

<Command>
Options



Help Menu Commands

Index
Keyboard
Commands
Procedures
Using Help
About PowerPad



Editing Text

Copying Text
Cutting Text
Pasting Text
Deleting Text
Finding Text
Changing Text
Undoing Edits



Formatting Text

Setting Tab Stops
Wrapping Text



Printing

Printing Files
Changing Printers and Printer Options
Printing Headers and Footers
Setting Margins



Running Other Programs

Configuring the Run Menu
Using the Run Menu



ShareWare Registration

Registering PowerPad



Selecting Text

Using the Mouse to Select Text
Selecting All the Text in a File



Working with Files

Creating New Files
Opening Existing Files
Merging Existing files
Saving Files
Setting File Preferences
Viewing File Statistics



New command - File Menu

Creates a new file.

If the current file has been changed since it was last saved, PowerPad asks you if you would 
like to save the changes before it creates a new file.

When you save the file, PowerPad prompts you for the file name and path.

Related Topics:
Creating New Files



Open command - File Menu

Opens and existing file.

If the current file has been changed since it was last saved, PowerPad asks you if you would 
like to save the changes before it lets you select a new file to open.

When you open a file, the file name appears in the caption bar of the main PowerPad 
window.

PowerPad can Open any file, provided that it contains only text with no special formatting 
characters besides tabs and carriage returns.    PowerPad has a file size limit of exactly 
45,000 characters.

Related Topics:
Opening Existing Files



Merge command - File Menu

Merges the text of an existing file into the file currently being edited at the insertion point.

PowerPad can Merge any file that it can otherwise Open, provided that the resulting file 
would be within the 45,000 character limit.

Related Topics:
Merging Existing Files



Save command - File Menu

Saves any changes to the current file.

If the file was created with the File\New command, PowerPad will prompt you for a file name 
and path.

After the file is saved, it remains open so that you can continue editing.

Related Topics:
Saving Files



Save As command - File Menu

Saves a new or existing file.

Save As allows you to:
* Name a new file, or
* Save a file with a new name, without changing the original file.

After the file is saved, it remains open so that you can continue editing.    The name in the 
caption bar will be changed to reflect the new name of the file.

Related Topics:
Saving Files



Preferences command - File Menu

Allows the user to view and modify File Preferences.

File Preferences include the default file extensions that appear in the File\Open and File\
Merge dialog boxes, as well as the default file name for saving unnamed files.

The file preferences will be saved in the PowerPad configuration, so that they will be in effect
in future PowerPad sessions.

Related Topics:
Setting File Preferences 



Print command - File Menu

Prints one copy of the current file.

The 'Printing' dialog box displays the current file name, as well as the device and port that 
the file is being printed to.

You can cancel the Print operation from the 'Printing' dialog if you wish.

Related Topics:
Printing Files
Changing Printers and Printer Options
Printing Headers and Footers
Setting Margins



Page Setup command - File Menu

Allows you to set the headers and footers for printed output, as well as printed page 
margins.

You can specify:
* Margins, or
* Headers or Footers, by text and/or code.

Header and Footer codes:

Code Description (format)
&f File Name (FILENAME.EXT)
&p Page Number
&d Date (MM/DD/YY)
&t Time (HH:MM)
&l Left justify text or codes that follow
&r Right justify text or codes that follow
&c Center text or codes that follow

The codes and text can be combined for complex headers and footers.    For example:

&lYourName&c&f&rPage &p

would produce and header or footer with 'YourName' at the left margin, the file name in the 
center, and the word 'Page' followed by a space and the page number at the right margin.

The header, footer, and margins will be saved in the PowerPad configuration, so that they 
will be in effect in future PowerPad sessions.

Related Topics:
Printing Headers and Footers
Setting Margins



Printer Setup command - File Menu

Sets printer options for PowerPad.

Printer Setup allows you to select the current printer for PowerPad.

Printer Setup also allows you to change the options for a printer.    The options will vary 
depending on the type of printer.

If the printer is not selected prior to printing, PowerPad uses the printer that was defined as 
the default by Windows setup or the control panel.

Related Topics:
Printing Files
Changing Printers and Printer Options



Exit command - File Menu

Closes the current file and exits PowerPad.

If the current file has been changed since it was last saved, PowerPad asks you if you would 
like to save the changes before it exits.

The current window size, position, and state (maximized, etc)    will be saved in the PowerPad
configuration, and they will be used as the defaults for the next PowerPad session.



Undo command - Edit Menu

Undo the last editing action.

You can Undo text edits or cut and paste operations.    If the action cannot be undone, Undo 
appears dimmed in the Edit menu.

Related Topics:
Undoing Edits



Cut command - Edit Menu

Deletes selected text from the current file and places it onto the Clipboard, replacing the 
previous Clipboard contents.

You can use Paste to place the Clipboard text in the same file, another file, or another 
application.

Related Topics:
Cutting Text
Pasting Text
Deleting Text



Copy command - Edit Menu

Copies selected text from the current file and places it onto the Clipboard, replacing the 
previous Clipboard contents.    The current file remains intact.

You can use Paste to place the Clipboard text in the same file, another file, or another 
application.

Related Topics:
Copying Text
Pasting Text



Paste command - Edit Menu

Pastes a copy of the current Clipboard contents at the insertion point, or replaces any 
selected text with the Clipboard contents.

Related Topics:
Cutting Text
Copying Text
Pasting Text



Delete command - Edit Menu

Deletes selected text from the file.

The Clipboard is not affected by this action.    Use delete to delete text when you want to 
keep the Clipboard contents intact.

Related Topics:
Deleting Text



Select All command - Edit Menu

Selects all of the text in a file.

Use Select All to quickly select all of the text in a file so that you can delete it or copy it to 
the Clipboard.

Related Topics:
Selecting All the Text in a File



Tabs command - View Menu

Sets the Tab stop for PowerPad.

PowerPad prompts you for the new Tab stop.    The range must be from 1 to 20 spaces.    The 
Tab stop is repeated.    For example, if the Tab stop is 8, the Tabs will be every 8 spaces.

The Tab stops will be saved in the PowerPad configuration, so that they will be in effect in 
future PowerPad sessions.

Related Topics:
Setting Tab Stops



Wordwrap command - View Menu

Turns word wrapping on or off.

Word wrapping is when PowerPad automatically breaks lines of text so that the entire line is 
shown in the current window.

Wordwrap is turned on when a check mark is displayed next to the Wordwrap menu item in 
the View menu.    Selecting the Wordwrap menu item toggles the Wordwrap state.

The Wordwrap state (on or off) will be saved in the PowerPad configuration, so that it will be 
in effect in future PowerPad sessions.

Related Topics:
Wrapping Text



Find command - Search Menu

Find searches for characters, words, or phrases in a file.

You can specify these options:
* Find what - enter the text to be searched for.
* Whole word - select this box to specify that the text must be delimited by a non-
alphanumeric character in order to qualify.
* Match Upper/Lowercase - select this box to specify that the text must match based on 
upper and lower case in order to qualify.
* Forward or Backward - select the direction of the search from the insertion point or current 
selection.

PowerPad will use any selected text (if the selection is less that 40 characters) as the default
for 'Find What'.    If no text is selected, the 'Find What' from the previous find is used as the 
default.

PowerPad displays a message if the beginning or end of a file is reached without finding the 
specified text.

Related Topics:
Finding Text



Repeat Find command - Search Menu

Repeat Find repeats the previous Find command.

Related Topics:
Finding Text



Change command - Search Menu

Change searches for characters, words, or phrases in a file and replaces occurrences with 
specified text.

You can specify these options:
* Find what - enter the text to be searched for.
* Change To - enter what the text should be changed to.
* Whole word - select this box to specify that the text must be delimited by a non-
alphanumeric character in order to qualify.
* Match Upper/Lowercase - select this box to specify that the text must match based on 
upper and lower case in order to qualify.
* Confirm Changes - select this box if you want to manually verify each change before it is 
made.

PowerPad will use any selected text (if the selection is less that 40 characters) as the default
for 'Find What'.    If no text is selected, the 'Find What' from the previous find is used as the 
default.

Change searches forward from the insertion point or selected text.    When the end of file is 
reached, PowerPad asks you if you would like to continue the Change operation from the 
beginning of the file.

PowerPad returns a count of the number of occurrences changed at the completion of the 
Change procedure.

Related Topics:
Changing Text



Goto Line command - Search Menu

Goto Line locates and selects a desired line by line number.

Choose the Goto Line command and enter the line number.    PowerPad will warn you if the 
line number is invalid.

Related Topics:
Viewing File Statistics



<Command> - Run Menu

Selecting a user defined command from the Run menu causes that command to be executed
by Windows.

Related Topics:
Configuring the Run Menu
Using the Run Menu



Options command - Run Menu

Run Options allows the user to define commands to be executed by Windows.

Enter the Menu Item title that you wish to appear in the Run menu, and the desired 
command as you would from the Program Manager Run command.

If the Menu Item and the Command are valid, the menu item will appear on the Run menu.

The user defined Run commands will be saved in the PowerPad configuration, so that they 
will be in effect in future PowerPad sessions.

Related Topics:
Configuring the Run Menu
Using the Run Menu



Index command - Help Menu

This command invokes Microsoft Windows Help and displays the PowerPad Help Index.

Related Topics:
Using Help



Keyboard command - Help Menu

This command invokes Microsoft Windows Help and displays the PowerPad Keyboard Help.

Related Topics:
Using Help



Command command - Help Menu

This command invokes Microsoft Windows Help and displays the PowerPad Command Index.

Related Topics:
Using Help



Procedure command - Help Menu

This command invokes Microsoft Windows Help and displays the PowerPad Procedure Index.

Related Topics:
Using Help



Using Help command - Help Menu

This command invokes Microsoft Windows Help and displays the Using Help Index.

Choose this option if you need to learn how to use Help.



About PowerPad command - Help Menu

This command displays the About PowerPad dialog.

The About PowerPad dialog contains the version number and copyright notice for PowerPad.

In addition, the number of characters and the number of lines in the current file is shown in 
the About dialog.

PowerPad ShareWare registration information is avialable by choosing the 'Registration' 
button.

Choose 'OK' to resume editing the current file.

Related Topics:
Registering PowerPad
Viewing File Statistics



Copying Text

To copy text to the clipboard:

1. Select the text.

2. Choose the Copy command from the Edit menu, or press the Ctrl + Ins key combination.

Related Topics:
Copy Command



Cutting Text

To cut text to the clipboard:

1. Select the text.

2. Choose the Cut command from the Edit menu, or press the Shift + Del key combination.

Related Topics:
Cut Command



Pasting Text

To paste text into a file from the clipboard:

1. Move the insertion point to where you want the text to appear, or select the text to be 
replaced.

2. Choose the Paste command from the Edit menu, or press the Shift + Ins key combination.

Related Topics:
Paste Command



Deleting Text

To delete a single charachter:

* Press BkSp to delete the character to the left of the insertion point, or
* Press Del to delete the character to the right of the insertion point.

To delete more than one character:

1. Select the text to be deleted.

2. Press the BkSp or Del key, or choose the Delete command from the Edit menu.

Note: If you wish to replace the Clipboard contents with the deleted text, you should use the 
Copy command.

Related Topics:
Copy Command
Delete Command
Copying Text



Finding Text

To find specific characters, words, or phrases in a file:

1. Move the insertion pointer to the place where you wish to start searching from.

2. Choose the Find command from the Search menu.

3. Enter the desired criteria for the find and choose OK.

4. Choose the Repeat Find command from the Search menu, or press the F3 key, to find the 
next occurrence.

Note: The criteria for the Find command are explained in the Find command help topic.

Find Command
Repeat Find Command



Changing Text

To find specific characters, words, or phrases in a file and replace them with 
specified text:

1. Move the insertion pointer to the place where you wish to start searching from.

2. Choose the Change command from the Search menu.

3. Enter the desired criteria for the change and choose OK.

Note: The criteria for the Change command and the explanation of its operation are 
explained in the Change command help topic.

Change Command



Undoing Edits

To undo an edit:

Choose Undo from the Edit menu or use the Alt + BkSp key.

Related Topics:
Undo Command



Setting Tab Stops

To set tab stops:

1. Select the Tabs command from the View menu.

2. Enter the number of spaces to be used for the tab stop.

Related Topics:
Tabs Command



Wrapping Text

To toggle wordwrap on and off:

Select the Wordwrap command from the View menu.

Related Topics:
Wordwrap Command



Printing Files

To print one copy of the current file:

Choose the Print command from the File menu.

Related Topics:
Print command



Changing Printers and Printer Options

To change printers:

1. Choose Printer Setup from the File menu.

2. Select the desired printer.

3. Choose OK.

To change printer options:

1. Choose Printer Setup from the File menu.

2. Select the desired printer.

3. Choose Setup.

4. Modify printer options and choose OK.

Related topics:
Printer Setup command



Printing Headers and Footers

To select a header or footer for a printed file:

1. Choose Page Setup from the File menu.

2. Enter the header and/or footer.

3. Choose OK.

See Page Setup command for details on header and footer codes.

Related topics:
Page Setup command



Setting Margins

To set margins for the printed file:

1. Choose Page Setup from the File menu.

2. Enter the margin values in inches.

3. Choose OK.

Related topics:
Page Setup command



Configuring the Run Menu

To configure the Run menu:

1. Choose Options from the Run menu.

2. Enter the run option title(s) to appear in the Run menu and the corresponding Run 
command.    The Run command should be formatted as if it were being entered from the Run 
option of the Program Manager.    You can run Windows or DOS applications with optional 
command line parameters.

3. Choose OK.

Related topics:
Options command
Using the Run Menu



Using the Run Menu

To use a run menu item:

1. Select the desired item from the Run menu.

2. The run command will be executed.

Note: Select the Options command from the Run menu to view the current list of Run 
commands.

Related topics:
Run Menu commands
Options command
Configuring the Run menu



Registering PowerPad

PowerPad is offered as shareware.    It is NOT FREE and it is NOT PUBLIC DOMAIN.    If you use
PowerPad after your initial evaluation you are obligated to register it.

To register PowerPad:

1. Select the About... command from the Help menu.

2. Choose the Registration button.

3. Follow the Registration instructions.

4. Choose OK.

Registration of this product will ensure future releases of this product with desired 
enhancements, and of other new and useful products.

Registration of any version of PowerPad will cover all future versions of PowerPad as well.

Related topics:
About PowerPad command



Using the Mouse to Select Text

Text selection with the mouse works like any other windows application with the following 
exceptions:

Right Mouse Button click:

The right mouse click will extend the selection from the insertion pointer to the point of the 
mouse when the right button was clicked.    This is the same as using a Shift-Left click.

Left Mouse Button double-click:

The left mouse button double click selects the word or whitespace that is currently under the
mouse pointer.    The word selection uses and non-alpha numeric character as a word 
separator, including spaces, tabs, and carriage returns.    The white space selection uses any 
character other than space ot tab as a separator.

Note: These rules differ from standard Windows text selection.    They are intended to help 
you select and edit text more quickly and efficiently.



Selecting All the Text in a File

To select all of the text in a file:

* Choose the Select All command from the Edit menu.

Related topics:
Select All command



Creating New Files

To create a new file:

* Choose the New command from the File menu.

Related topics:
New command



Opening Existing Files

PowerPad works with text files only.    The file size limit is 45,000 characters.

To open an existing file:

1. Choose the Open command from the File Menu.

2. Select the file to open.

3. Choose OK.

Related topics:
Open command



Merging Existing Files

To insert the contents of a file into the current file:

1. Move the insertion pointer to where you want the text to appear. 

2. Choose the Merge command from the File Menu.

3. Select the file to insert.

4. Choose OK.

Related topics:
Merge command



Saving Files

To save changes to the current file:

* Choose the Save command from the File menu.

To save the current file under a different name:

1. Choose the Save As command from the file menu.

2. Enter the desired file name.

3. Choose OK.

Note: If Save is chosen for an unnamed file, the Save As dialog will automatically appear so 
that the file can be named before it is saved.

Related Topics:
Save command
Save As command



Setting File Preferences

To set the preferences for File Open, Merge, and Save As commands:

1. Choose Preferences from the File menu.

2. Set the default file extensions and the default file name.

3. Choose OK.

Related Topics:
Preferences command



Viewing File Statistics

To view the number of lines in a file and the number of characters in a file:

* Choose the About command from the Help menu.

Related topics:
About PowerPad command


